Known issues in Greenplum Database related to Greenplum loader (gpload, gpfdist)

posted Jan 25, 2014, 8:28 AM by Sachchida Ojha   [ updated Nov 4, 2014, 9:04 AM ]
1. Issue 19705
gpload fails on Windows XP with Python 2.6. 
Workaround: Install Python 2.5 on the system where gpload is installed.
The gadget spec URL could not be found
2. Issue 18774
External web tables that use IPv6 addresses must include a port number.

3. Issue 18703
The bytenum field (byte offset in the load file where the error occurred) in the error log when using gpfdist with data in text format errors is not populated, making it
difficult to find the location of an error in the source file.

4. Issue 18785
Running gpload with the --ssl option and the relative path of the source file results in an error that states the source file is missing.
Workaround: Provide the full path in the yaml file or add the loaded data file to the certificate folder.

5. Issue 18414
Unable to define external tables with fixed width format and empty line delimiter when file size is larger than gpfdist chunk (by default, 32K).
The gadget spec URL could not be found
6. Issue 17189
gpfdist shows the error “Address already in use” after successfully binding to socket IPv6. Greenplum supports IPv4 and IPv6. However, gpfdist fails to bind to socket IPv4, and shows the message “Address already in use”, but binds successfully to socket IPv6.
Comments